.ad l
.TH ldns 3 "30 May 2006"
.SH NAME
ldns_algorithm \- numbers assigned to algorithms used in dns

.SH SYNOPSIS
#include <stdint.h>
.br
#include <stdbool.h>
.br
.PP
#include <ldns/ldns.h>
.PP

.SH DESCRIPTION
.HP
\fIldns_algorithm\fR
.br
Algorithms used in dns
.br
enum ldns_enum_algorithm
.br
{
.br
        LDNS_RSAMD5             = 1,   /* RFC 4034,4035 */
.br
        LDNS_DH                 = 2,
.br
        LDNS_DSA                = 3,
.br
        LDNS_ECC                = 4,
.br
        LDNS_RSASHA1            = 5,
.br
        LDNS_DSA_NSEC3          = 6,
.br
        LDNS_RSASHA1_NSEC3      = 7,
.br
        LDNS_RSASHA256          = 8,   /* RFC 5702 */
.br
        LDNS_RSASHA512          = 10,  /* RFC 5702 */
.br
        LDNS_ECC_GOST           = 12,  /* RFC 5933 */
.br
        LDNS_ECDSAP256SHA256    = 13,  /* RFC 6605 */
.br
        LDNS_ECDSAP384SHA384    = 14,  /* RFC 6605 */
.br
	LDNS_ED25519		= 15,  /* RFC 8080 */
.br
	LDNS_ED448		= 16,  /* RFC 8080 */
.br
        LDNS_INDIRECT           = 252,
.br
        LDNS_PRIVATEDNS         = 253,
.br
        LDNS_PRIVATEOID         = 254
.br
};
.br
typedef enum ldns_enum_algorithm ldns_algorithm;
.PP
.SH AUTHOR
The ldns team at NLnet Labs.

.SH REPORTING BUGS
Please report bugs to dns-team@nlnetlabs.nl or on
GitHub at https://github.com/NLnetLabs/ldns/issues

.SH COPYRIGHT
Copyright (c) 2004 - 2006 NLnet Labs.
.PP
Licensed under the BSD License. There is NO warranty; not even for
MERCHANTABILITY or
FITNESS FOR A PARTICULAR PURPOSE.
.SH SEE ALSO
\fBperldoc Net::DNS\fR, \fBRFC1034\fR,
\fBRFC1035\fR, \fBRFC4033\fR, \fBRFC4034\fR and \fBRFC4035\fR.
.SH REMARKS
This manpage was automatically generated from the ldns source code.
